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WestPro is an add-in program designed to work with Microsoft Excel to simulate the
growth of uneven-aged Douglas-fir (Pseudotsuga menziesii (Mirb.) Franco) stands in the
Pacific Northwest region of the United States. Given the initial stand state, defined as the
number of softwood and hardwood trees per acre by diameter class, WestPro predicts
the future stand state for each year of a predetermined time horizon. Management re-
gimes are defined by a target stand distribution and a cutting cycle. Performance indica-
tors include diversity of tree size and species, timber yield, and net present value of
harvest over the given horizon.

This paper contains background information on the WestPro program and instructions
and suggestions for its application. By working the examples found in the text, the user
will learn how to simulate the growth of a given initial stand and to predict how different
management regimes may affect stand structure, yield, and diversity. Limitations of the
model also are discussed.

Keywords: Douglas-fir, Pseudotsuga menziesii, uneven-aged, management, economics,
ecology, WestPro, simulation, software, growth model, diversity.

Abstract



1 1. Introduction and Background Information

1 Before Beginning

1 What is WestPro?

1 Why Simulate This Type of Stand?

1 How Does WestPro Work?

1 2. Getting Started

1 Installing the WestPro Software

2 The WestPro Menu

2 3. A Basic WestPro Simulation

2 The Input Data Worksheet

4 The Stand Development Worksheet

5 The Production Worksheet

6 4. Managing Data in WestPro

6 Storing Data in WestPro

7 Deleting Stored Data

7 Retrieving Stored Data

8 5. Advanced WestPro

8 The BDq Calculator

9 Creating Charts

13 The Stock-and-Cut Table

16 Running Multiple Simulations

17 Interpreting the Examples

18 6. Troubleshooting and Further Program Applications

18 Model Restrictions

18 Program Restriction

18 Further Applications of WestPro

18 Acknowledgments

19 Metric Equivalents

19 Literature Cited

20 Glossary

21 Appendix A–WestPro Data

23 Appendix B–WestPro Model and Parameters

Contents



1

This paper provides background, instructions for using WestPro, and additional sugges-
tions for application of the program. The instructions go through each step of the ex-
amples (located in boxes throughout the manual). If you are new to WestPro, it will be
useful to run these examples while reading the paper.

This section describes WestPro’s purpose and background, section 2 shows how to
install the program and use the WestPro menu, section 3 offers instructions for perform-
ing basic, single-stand simulations, section 4 discusses how to store and retrieve data,
and section 5 provides instructions on using the more advanced features of the program.
Users who are unfamiliar with Microsoft Excel may also want to consult the Microsoft
Excel User’s Guide for additional help.

WestPro is a computer program designed to simulate the growth of uneven-aged
Douglas-fir (Pseudotsuga menziesii (Mirb.) Franco) stands over time. With this program,
different management regimes can be considered, and their outcomes can be predicted
quickly. WestPro is a useful tool for suggesting which management should be imple-
mented. Similar programs, such as SouthPro for loblolly pine (Pinus taeda L.) in the
Southern United States (Schulte et al. 1998), and NorthPro for hardwood stands in the
Lake States (Kolbe 1998), have already been developed. The WestPro software was
designed and calibrated for uneven-aged Douglas-fir stands in the Pacific Northwest re-
gion of the United States.

Timber production is a primary goal for a large portion of Douglas-fir stands, but at the
same time, concerns about sustainability and negative biological impacts are being
raised as a result of the visible adverse effects of current management practices (Curtis
and Carey 1996, Curtis and Marshall 1993). Because interest in silvicultural alternatives
to even-age management of Pacific Northwest forests is increasing, better information is
needed on the effects of these alternatives (Emmingham 1998). WestPro is meant to
add to the “toolkit” of foresters a method for predicting how a given stand might look in
the future, and what it might yield under uneven-age management.

The WestPro program uses a density-dependent matrix model calculated from data
for 66 uneven-aged Douglas-fir plots. The plots were in western Oregon and western
Washington and were measured by the Forest Inventory and Analysis Program of the
USDA Forest Service, Pacific Northwest Research Station (PNW-FIA). Each plot was
measured twice over an interval of approximately 10½ years. Simulations with the
WestPro model have produced, without apparent bias, results replicating the growth on
the observed plots, and long-term projections consistent with prior knowledge of uneven-
aged Douglas-fir stands (Ralston et al., in press).

The matrix model built in WestPro predicts growth, mortality, and the rate of regeneration
for softwoods and hardwoods as a function of basal area, site index, and individual tree
size when those variables are statistically significant. For details regarding the model
data, form, and parameters, see appendices A and B.

WestPro is an add-in program that works with Microsoft Excel for Windows.1 You will
need at least 16 megabytes of random access memory (RAM) to run WestPro. This
program works for most versions of Windows (from Windows 3.1 through Windows XP)
and Excel (from Excel 5.0 to Excel 2000).

1. Introduction and
Background
Information
Before Beginning

What is WestPro?

Why Simulate This Type
of Stand?

How Does WestPro
Work?

 2. Getting Started
Installing the WestPro
Software

1 The use of trade or firm names in this publication is for
reader information and does not imply endorsement by
the U.S. Department of Agriculture of any product or
service.
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To install the software, follow these steps:

• Insert the diskette or compact disk (CD) containing the WestPro Microsoft Excel
add-in.

• Open Microsoft Excel and start a new workbook.

• Under the Tools menu, select Add-ins. Once the add-ins dialog box appears, select
Browse and choose the WestPro add-in (WestPro.xla) from the drive containing the
diskette or CD. Click OK.

• The window that appears asks if you would like to copy WestPro to the add-ins folder
on your hard drive. Click OK.

• The WestPro program will appear in the list of the add-ins dialog box. Be sure the
box corresponding to the WestPro add-in is checked and click OK.

• Return to the Tools menu and notice that WestPro is now the last choice in the
menu. Select WestPro and click OK in the title box. A new box will appear, asking
you if you want the Input Data worksheet inserted. Click Yes to insert the new
worksheet.

• The WestPro menu appears before the File menu of the Excel menu bar.

While WestPro is running, all Excel functions are still available. Once WestPro is in-
stalled, it will remain an option under the Tools menu every time Excel is opened. To
uninstall WestPro, you must uncheck the corresponding box in the Add-ins list and quit
Excel.

The WestPro menu, in the upper left corner of the Excel menu bar, has seven options
(fig. 1). To stop the WestPro program and remove the menu, click the last option, Quit.
After you have quit the program, any worksheets you have added with WestPro will still
be present, but no WestPro function can be carried out without again starting WestPro
under the Tools menu.

The other six menu items are WestPro functions. Five have submenus, and under these
you will find additional functions. Figure 1 shows the WestPro menu and one of the
submenus.

While the program is running, the WestPro menu is present in all the workbooks open in
Excel. Thus, you can work with several simulations, in different workbooks, at the same
time.

Use the Input Data worksheet (fig. 2) to enter data about the stand you want to simulate
and the management you will use. WestPro is for uneven-aged Douglas-fir forests, and
recognizes two species groups, softwoods and hardwoods.

The initial distribution refers to the number of trees per acre, by species group, by 2-inch
diameter classes (fig. 2). For example, the diameter class labeled “4” includes all trees
with diameters greater than or equal to 3 inches and less than 5 inches.

The target distribution refers to the number of trees per acre, by species group, and by
size class that should remain after harvest (fig. 2). A target of zero instructs WestPro to
harvest all trees in that size class; you can prevent the removal of any tree by entering a
very high target, say 1,000. When there are more available trees than the target value,
then the harvest is the difference between the available trees and the target.

The WestPro Menu

 3. A Basic WestPro
Simulation
The Input Data
Worksheet
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Stumpage prices for sawtimber are by unit of volume and by size class, whereas for
pulpwood they are by weight only. The management schedule data include the first year
of the simulation, the year of the first harvest, the cutting cycle (interval between har-
vests), and the length of the simulation. The cutting cycle must be at least 2 years, even
if there is no harvest.

Other input data include the fixed costs (costs of re-entry at each harvest, independent
of the harvest), the interest rate, the site index (King 1966), and the state (OR or WA).

When you run a simulation, WestPro considers any empty input data cell an error and
will prompt you to fix it. You can enter zero for price, fixed cost, and interest rate if you
are not interested in financial information.

Figure 1—The WestPro menu.

Figure 2—The Input Data worksheet, containing the data to run example 1.
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The Stand Development worksheet gives the expected number of trees per acre by diam-
eter class and species group for each successive year. Figure 3 shows the part of the
Stand Development worksheet containing the diameter distribution of softwoods, for the
first 27 years from example 1.

Figure 3—Part of the Stand Development worksheet showing the diameter distribution of
softwoods over time (example 1).

The Stand Development
Worksheet

Example 1: A Single Simulation

Manually enter or copy the data in figure 2 into the Input Data worksheet on your com-
puter. To copy the data, open the Excel workbook named “Data for Example 1” located
on the WestPro diskette or CD. Copy and paste ranges B5:T8, B12:T15, and B18:B29
from the Data for Example 1 worksheet to the same location in your blank Input Data
worksheet.

In this example, the initial distribution corresponds to the average diameter distribution
of the plots in western Washington used to develop the WestPro model. The target
distribution for softwoods is the same as the initial distribution, whereas the target
distribution for hardwoods results in the removal of all trees larger than 11 inches in
diameter. The sawtimber and pulpwood prices were typical for the region in 1999
(Warren 2001). To perform a single simulation, select WestPro→Single
Simulation→Run. The results of the simulation are stored in two new worksheets,
Stand Development and Production.
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Figure 4—Part of the Stand Development worksheet showing the summary statistics
(example 1).

If you scroll right, past the diameter distributions for both species groups, you will find
the summary statistics, including the stand basal area, basal area by species groups,
species group diversity and size class diversity for each year (fig. 4). The species group
and size class diversity indices are based on basal area and measured by Shannon’s
Index (Pielou 1977, Shannon and Weaver 1963). Highest species group diversity occurs
when there is the same basal area in each species group, and highest size diversity
when there is the same basal area in each size class.

The Production worksheet (fig. 5) shows data for each harvest in terms of basal area
cut, gross income, and the pulpwood and sawtimber volumes cut for each species
group. The volumes are computed from equations linking tree volume to tree diameter
and stand basal area (see app. B). The spreadsheet also shows the net present value of
each harvest, the total net present value, and the annual production in basal
area and volume cut.

The Adjustable values box allows you to see the effect of different interest rates or fixed
costs, without having to rerun the simulation. The Production worksheet also shows the
input data, as a reminder of the assumptions made in this simulation.

The Production
Worksheet
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The previous section discussed a basic WestPro simulation, which is sufficient if you
only want to do one simulation. In that case, you can save the input data and results of
a single simulation as an Excel file by choosing File→Save As and giving an appropri-
ate name to the workbook. If, however, you would like to examine the effects of changing
some of the simulation parameters and run several simulations, you may find it more
efficient to manage data with the Setup Files feature of WestPro than to repeatedly set
up and save individual simulations.

For that purpose, once you have entered data in the Input Data worksheet, you can store
them for later use. When you store data, you are copying them from the Input Data work-
sheet to the Setup Files worksheet. The Setup Files worksheet acts as a holding area
for all the data you have stored. It also contains data sets built into the program. The
Setup Files worksheet is not visible, and you do not need to see it, but if you would like
to view it, see the instructions in section 6.

Figure 5—The Production worksheet for example 1.

4. Managing Data in
WestPro
Storing Data in WestPro
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Give detailed names to setup files. If you save many files, a detailed name will help you
choose the correct file when you want to retrieve it.

To delete setup files, choose WestPro→Setup Files→Delete. Select the field that you
want to delete a file from, and highlight that file in the list. After you hit Delete, only that
file is removed from the Setup Files worksheet.

Selecting WestPro→Single Simulation→Setup opens the Load Setup Files window
(fig. 7). With this window, you can copy data from the Setup Files worksheet to the Input
Data worksheet. If you have not added any data to the Setup Files worksheet, only the
built-in data will be available.

To select the data to load into the Input Data worksheet, highlight the file name in the
Initial Distribution list, the Softwoods Target list, and the other lists. To select the default
interest rate, site index, or state, place a checkmark in the Insert box. You can change
the default values by typing your choice in the respective text box. Click OK to copy the
selected setup files to the Input Data worksheet.

Example 2: Adding Setup Files

Select WestPro→Setup Files→Add. WestPro will ask you if you would like a copy
of the Setup Files worksheet inserted. Click Yes. The Add Setup Files window (fig. 6)
should appear on your screen.

Check the Add the Target Distribution box, make sure that softwoods are selected,
and name the softwood target distribution “Average WA SW.”

Check the Add the Management Schedule box and name it “Start 0,Cut 5,Cycle
20,205 Yr.”

Check the Add the Fixed Costs box and name it “10.”  Click OK.

As each file is copied, you may choose its position in the list of files. The names al-
ready shown in the lists are the setup files built into WestPro. Insert your setup files at
the top of each list.

You need not copy the initial distribution, the hardwood target distribution, or the
prices because they are built in as “Average WA plots,” “11 inch max. diameter,” and
“Example Price 1,” respectively.

Figure 6—The Add Setup Files
window (example 2).

Deleting Stored Data

Retrieving Stored Data
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To preview the data before loading them, click the appropriate button in the Preview se-
lection box and click the Show button at the top of the window. For example, clicking
Show in the window in figure 7 would show the initial distribution in the file named Aver-
age WA plots.

This calculator is meant to calculate the number of trees by size class in a stand with
a specific BDq distribution (see “Glossary”) (Smith 1997). The q-ratio is the ratio of the
number of trees in successive size classes.

Going to WestPro→ Setup Files→BDq Distributions opens the BDq calculator (fig. 8).
Use the arrow buttons to set the basal area (ft2/acre), the maximum diameter (in), the q-
ratio, and the minimum diameter (in) to the desired level, then click the Calculate but-
ton. Figure 8 shows the number of trees in each size class that would give a basal area
of 125 ft2/ac, with trees of diameters from 3 to 31 in, and a q-ratio of 1.4.

You can copy the calculated distribution to the Input Data worksheet as the initial distri-
bution or as the target distribution for either softwoods or hardwoods by selecting the
destination and clicking the Copy button. Clicking the Cancel button closes the calcula-
tor window.

Figure 7—The Load Setup Files window.

5.  Advanced
WestPro
The BDq Calculator

Figure 8—The BDq Distribution Calculator window.
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WestPro lets you create charts with data from the Stand Development worksheet and
from the Production worksheet. Under the WestPro menu there are two headings, Stand
Development Charts and Production Charts, each containing different chart types. To
create one of the Stand Development charts, the Stand Development worksheet (figs. 3
and 4) must be visible; otherwise WestPro will prompt you to put this sheet in front.
Similarly, to create a Production chart, the Production worksheet (fig. 5) must be visible.

There are four stand development charts:

• Size diversity (Shannon index)

• Species diversity (Shannon index)

• Size distribution (trees/acre)

• Stand basal area (ft2/acre)

There are three production charts:

• Basal area cut (ft2/acre)

• Gross income ($/acre)

• Volume cut (ft3/acre)

The seven chart types are shown in figures 9 through 15. You can choose the year or
range of years of the data. For the size distribution (fig. 11b) and stand basal area (fig.
12) charts, you also can select the species groups to plot, and for the volume cut chart,
you can select the species and product (fig. 15a) to plot.

Creating Charts

Figure 9—Chart of size diversity.
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Figure 10—Chart of species
group diversity.

Figure 11a—Size Distribution Chart window
(example 3).

Figure 11b—Chart of size distributions (example 3).
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Figure 12—Chart of stand basal
area.

Figure 13a—Basal Area Cut Chart window
(example 4).

Figure 13b—Chart of basal area cut (example 4).
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Figure 14—Chart of gross
income.

Figure 15a—Volume Cut Chart window.

Figure 15b—Chart of volume cut.
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Highlighting one year in the Size Distribution Chart window will plot the distribution for a
single year. To plot sequential years, highlight the first year, press the Shift key, and then
click the last year to plot all of the years between. To plot multiple, nonsequential years,
click each year to plot while holding down the Ctrl key.

Example 4: Charting Basal Area Cut

To get a bar chart of the basal area cut at each harvest, do the following. With the Pro-
duction worksheet produced by example 1 in the foreground, select
WestPro→Production Charts→Basal Area Cut. When the Basal Area Cut Chart
window appears (fig. 13a), leave the default selection (First Year: 5, Last Year: 205) as
the years to plot. Click OK and name the chart “BACut” (fig. 13b).

The Stock-and-Cut table gives information on the immediate effects of harvesting a par-
ticular initial stand to a target stand, and on how to do the harvest. The Stock-and-Cut
table in figure 16 (on two pages) shows the initial stand and its annual growth (predicted
by WestPro), the target stand and its annual growth, and the residual stand after harvest
and its annual growth. The marking guide in the last column shows how the pole, small
sawtimber, medium sawtimber, and large sawtimber trees should be selected for harvest.

Example 5: Generating a Stock-and-Cut Table

To get the Stock-and-Cut table in figure 16, with the year 25 stand obtained in example
1 as initial stand, and the target stand in example 1, do the following. With
the Stand Development worksheet produced by example 1 in the foreground, select
WestPro→Stock-and-Cut Table. In the Stock-and-Cut Table window (fig. 17a), click
the Stand Development button to select that worksheet as the location of the initial
and target stand distributions.

Next, in Stock-and-Cut Stand Development Selection window (fig. 17b), choose the
Initial Distribution year of 25, and leave the selected Target Distribution as Target. Click
Table to generate the Stock-and-Cut table in a new worksheet. Click Cancel to close
the Stock-and-Cut Table window.

From the Stock-and-Cut Table window (fig. 17a), you also can choose data in the Setup
Files or Input Data worksheets. Choosing the Input Data worksheet as the data source
selects the preharvest and target distributions on that worksheet. Choosing the Setup
Files worksheet as the data source opens a window that allows you to choose from the
distributions in that worksheet (see section 4, “Storing Data in WestPro”).

Example 3: Charting Size Distribution

To chart size distribution for hardwoods and softwoods the year before and after the
second harvest, do the following. With the Stand Development worksheet produced by
example 1 in the foreground, go to WestPro→Stand Development Charts→Size
Distributions. When the Size Distribution Chart window (fig. 11a) appears, highlight
year “25,” press the Shift key, then highlight year “26” also. Check both species
groups. Click OK, and name the chart “SizeDist25,26” when prompted (fig. 11b).

The Stock-and-Cut Table
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Figure 16—Stock-and-Cut table
(example 5).
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Figure 16—Stock-and-Cut table
(example 5), continued.
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Figure 17a—Stock-and-Cut Table window.

Figure 17b—Stock-and-Cut Stand Development Selection window (example 5).

You can run many simulations sequentially. The results of each simulation are saved in a
separate workbook containing only the Stand Development and Production worksheets.

Example 6: Running a Batch of Simulations

Note: The data used in this example will only be available if you have done the previous
examples.

Choose WestPro→Multiple Simulations→Setup. Click Yes when asked if you would
like the Batch File worksheet (fig. 18) inserted. The Update Batch File window (fig. 19)
will appear on your screen. Highlight “Average WA plots” as the initial distribution, “Av-
erage WA SW” as the softwoods target, “11 inch max. diameter” as the hardwoods
target, “Start 0,Cut 5,Cycle 20,205Yr” as the management schedule, “Example Price 1”
as the stumpage prices, and “10” as the fixed costs. Leave the interest rate, site index,
and state at the default settings of 3, 96, and WA, respectively. Click the ADD button.
Change the interest rate to 5 (percent per year) and click ADD. Next, change the site
index to 115 (feet) and click ADD again. Finally, change the Hardwoods Target to “7
inch max. diameter” and click ADD, then click Close to close the window.

Choose WestPro→Multiple Simulations→Run. Click Yes to confirm, then select a
destination drive and save each simulation as the default name (in the last column of
fig. 18) by clicking Save. Click Yes to run the batch of simulations. The final batch
worksheet should look like figure 18, but the locations of your saved workbooks may
be different.

Running Multiple
Simulations
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In the upper left corner of the Update Batch File window (fig. 19) is a run number that
corresponds to the simulation number in the Batch File worksheet (fig. 18). When first
preparing a set of simulations to run, start with run number 1. After setting up a file and
clicking ADD, the Update Batch File window remains open to setup run number 2, and
this continues until you click Cancel. Notice the cells labeled “First simulation to run”
and “Last simulation to run” at the top of the Batch File worksheet. These fields will auto-
matically adjust to the number of batches you add. However, if you want to run only cer-
tain sequential simulations, you can manually enter the run numbers in those fields of
the worksheet.

After working out the examples, you should have a better understanding of WestPro’s
capabilities. You can look at the predictions on worksheets and charts to determine if
the stand structure is sustainable over time. The examples presented in this paper ex-
hibit an increase in size diversity (fig. 9) but a decrease in species group diversity (fig.
10) over time, while the stand basal area (ft2/acre) decreases at first and then reaches a
sustainable level (fig. 12). Also, the production predictions reveal that the total basal area
cut (ft2/acre), gross income (dollars/acre), and volume cut (ft3/acre) reach steady levels
over time (figs. 5, 13b through 15). The above examples represent only one possible
management regime for an uneven-aged stand. You can use WestPro to investigate
others.

Figure 18—Batch File worksheet (example 6).

Figure 19—Update Batch File window (example 6).

Interpreting the
Examples
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The WestPro software is intended to serve as a guide for the management of uneven-
aged Douglas-fir stands. Its equations represent the expected development of stands
based on observations from 66 plots on wide-ranging sites in Washington and Oregon.
Thus, like other models, WestPro predicts average expected values. Although it may not
predict accurately the observed growth and yield on an individual stand, its predictions
should be close to the average growth and yield over many stands (Ralston et al., in
press).

The WestPro program automatically corrects errors, or prompts users to correct errors
in data entry. However, some errors may still go undetected. The following information
will help you prevent or correct those errors.

Many of the worksheet cells in which you need not enter or change data are protected.
This protection can be removed by going to the Tools→Protection→Unprotect Sheet.
You will be prompted to enter a password, “Douglas-fir.”  If you remove the protection,
you will be able to make changes in the sheet format. However, WestPro is designed to
reference particular cells or ranges of cells. Any change to the format could produce an
error or unintended results.

You can view the data in the Setup Files worksheet by going to Format→Sheet→
Unhide. When the Unhide window opens, choose Setup Files and that sheet will now
be visible. If you change the format or enter data directly into the Setup Files worksheet,
however, it will most likely result in an error.

Other errors can result when the management schedule does not make sense. WestPro
is prepared for many errors of this kind and will instruct you on how to correct the prob-
lem. WestPro does have restrictions on the management schedule parameters. The
maximum length of simulation is 2,000 years, no more than 254 harvests can be per-
formed, and you must enter a cutting cycle greater than 1 year. Also, you cannot run
more than 500 batch simulations at one time.

This manual does not suggest a particular management regime for uneven-aged
Douglas-fir stands, but using the WestPro software may help you choose a regime,
based on the predicted economic and ecological consequences of different approaches.
Although the example used in the paper has emphasized only a few methods of setting
target distributions, target distributions of any shape could be investigated with WestPro.
Coupled with the flexibility of setting cutting cycles, and targeting hardwoods as well as
softwoods, WestPro is a tool with a wide range of applications for multipurpose forestry
in the Pacific Northwest.

The research leading to this paper was supported, in part, by the USDA Forest Service,
Pacific Northwest Research Station, Forest Inventory and Analysis Program, by USDA-
CSREES grant 2001-35108-10673, and by the School of Natural Resources, University
of Wisconsin, Madison. We thank Bryan Lu, Tara Barett, and Ed deSteiguer for their
comments on WestPro and this users manual, while we take sole responsibility for the
final products.
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and Further Program
Applications
Model Restrictions

Program Restriction

Further Applications of
WestPro
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When you know: Multiply by: To find:

Inches (in) 2.54 Centimeters
Feet (ft) .304 Meters
Square feet (ft2) .0929 Square meters
Cubic feet (ft3) .0283 Cubic meters
Acres (ac) .405 Hectares
Square feet per acre (ft2/ac) .2293 Square meters per hectare
Cubic feet per acre (ft3/ac) .06997 Cubic meters per hectare
Trees per acre 2.471 Trees per hectare
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BDq distribution—A diameter distribution defined by stand basal area (ft2/acre), maxi-
mum and minimum tree diameters (in), and a q-ratio, the ratio of trees per acre in a di-
ameter class to the number of trees per acre in the next larger class.

Cutting cycle—The time interval between successive harvests in an uneven-aged stand.

DBH—The diameter of a tree recorded at breast height.

Fixed costs—The costs per acre not included in the stumpage price.

Initial distribution—The number of trees per acre in each diameter class, for both spe-
cies groups, at year zero.

Management schedule—The time parameters of the stand simulation, including the
first year of simulation, year of first harvest, the cutting cycle, and the length of the simu-
lation.

Marking guide—The portion of the Stock-and-Cut Table that indicates the number of
pulpwood and sawtimber trees that are cut from the initial distribution as dictated by the
target distribution.

Net present value—The net revenue (gross income minus fixed costs), discounted to
the present.

tr

CR
NPV

)1( +
−=      ,

where R is the gross income (dollars/acre), C is the fixed cost (dollars/acre), r is the real
interest rate (percent/year), and t is the number of years in the future. The total net
present value is the sum of the net present value over all harvests.

Pulpwood—All softwood trees with a diameter smaller than 9 inches and all hardwood
trees with diameters smaller than 11 inches.

Sawtimber—Trees large enough to produce sawlogs. All softwood trees with a diameter
of 9 inches or larger and all hardwood trees with diameter of 11 inches or larger.

Site index—The average height of the five dominant Douglas-fir trees at 50 years of age.
Original database measurements used King’s selection method (King 1966).

State—The state where your stand is located, either Washington (WA) or Oregon (OR).
The distinction is made because, all other things being equal, hardwoods in Washington
grow faster than in Oregon, according to the data used to develop the growth equations.

Target distribution—The number of trees per acre, by diameter class and species
group, desired after each harvest.

Glossary
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This appendix summarizes the data used to develop the equations for the density-depen-
dent matrix model used in the WestPro program. More detail on the data, equations, and
model estimation and validation can be found in Ralston et al. (in press).

The data came from sample plots in Oregon and Washington measured by the Forest
Inventory and Analysis Program (FIA) at the USDA Forest Service, Pacific Northwest
(PNW) Research Station. All the plots had been measured at two successive inventories.
The most recent inventory was conducted in 2000 in the state of Washington and be-
tween 1995 and 1997 in Oregon. The previous inventories occurred between 1988 and
1990 in Washington, and between 1984 and 1986 in Oregon.

The selected plots had the following characteristics: the primary forest type was
Douglas-fir, the plot had been measured twice, and it was classified as timberland
and uneven-aged. This gave 43 plots in Oregon and 23 in Washington.

Trees with a diameter at breast height of more than 3 inches were used to estimate
model equations. The trees were grouped into softwoods or hardwoods. The primary
softwood species were Douglas-fir (Pseudotsuga menziesii (Mirb.) Franco) and western
hemlock (Tsuga heterophylla (Raf.) Sarg), and the most common hardwoods included
bigleaf maple (Acer macrophyllum Pursh), red alder (Alnus rubra Bong.), and Pacific
madrone (Arbutus menziesii Pursh).

The matrix model in WestPro predicts growth, mortality, and ingrowth for softwoods and
hardwoods as a function of basal area, site index, and individual tree size when those
variables are statistically significant. The WestPro program also employs equations to
predict volume from tree characteristics and stand basal area. Appendix B summarizes
the equations and their parameters.

The dependent variables for the four equations were:

• The diameter growth rate of each tree, in inches per year, estimated from the
difference in diameters at the time of the two inventories, divided by the number of
years between inventories.

• The tree mortality between the two inventories, recorded as a binary variable: 1 if a
tree had died, and 0 if it stayed alive.

• The ingrowth, or the number of trees per acre per year entering the smallest diameter
class between the two inventories, measured on each plot.

• The tree volume, in cubic feet, recorded in the FIA database.

The explanatory variables were:

• The individual tree size, measured as diameter at breast height in inches, at the first
inventory.

• The site index, measured by the height, in feet, of the dominant tree on the plot at
age 50.

• The stand basal area, in square feet per acre, of all the trees of diameter larger than
3 inches on the plot in which a particular tree was growing.

The summary statistics for all the variables are in table 1. The data from Washington and
Oregon have been combined because there was no statistical difference in the model
parameters between the two states, except for the hardwood growth equation, which
showed a slightly faster growth in Washington (see table 2 in app. B).

Appendix A—
WestPro Data
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Table 1—Summary statistics for tree and plot data used in parameter estimation

 Diameter growth Diameter

Softwoods Hardwoods Softwoods Hardwoods Site index Basal area

– – – – Inches per year – – – – – – – – – – Inches – – – – – – Feet Square feet
per acre

Mean 0.19 0.10 17.43 11.55 95.96 150.71
S.D. .12 .09 10.14 6.54 23.41 66.47
Max .69 .62 64.09 38.23 145.93 353.13
Min .00 .00 3.03 3.03 47.21 52.95

 – – – – – – – – – – – – – – – – – – – – – – – – Sample size – – – – – – – – – – – – – – – – – – – – – – – – –

N 1,387 187 1,387 187 66 66

Mortality rate
(between inventories) Ingrowth Tree volume

Softwoods Hardwoods Softwoods Hardwoods Softwoods Hardwoods

– – – – – – – – – – – – Trees per acre per year – – – – – – – – – – – – – – – – – Cubic feet – – – –

Mean 0.04 0.10 1.99 0.74 103.03 35.27
S.D. .19 .30 4.81 2.31 123.13 46.17
Max 1.00 1.00 30.48 13.41 967.83 383.00
Min .00 .00 .00 .00 .80 .50

– – – – – – – – – – – – – – – – – – – – – – – – – Sample size – – – – – – – – – – – – – – – – – – – – – – –

N 1,472 271 66 66 1,375 161
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The growth model uses a density-dependent matrix form, similar to that used by Lin et
al. (1998) and Kolbe et al. (1999).

ttttt IhyGy +−=+ )(1 , (1)

where y
t
 is a column vector representing the number of live trees per acre, y

t
=[y

ijt
], where

i is the tree species, j is the diameter class, and t is the year. The column vector h
t
=[h

ijt
]

represents the number of trees of species i and diameter class j harvested in year t. The
growth matrix G
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 is defined as:
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where n is the number of diameter classes, b
ijt
 is the probability that a tree of species i

and in diameter class j at t is alive and in diameter class j+1 at t+1, while a
ijt
 is the prob-

ability that the same tree is alive and still in diameter class j at t+1. The subscript t indi-
cates that the probabilities a and b vary over time because they are functions of stand
density.

If we let the m
ijt
 be the probability that a tree of species i and diameter class j dies be-

tween t and t+1, then a
ijt 
is given by:

a
ijt
 = 1- b

ijt 
- m

ijt .  
(3)

The ingrowth matrix, I
t
, is a column vector that contains the ingrowth for each species

group at time t.
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where I
it
 is the ingrowth of species i, that is the number of trees that enters diameter

class 1 between year t and year t+1. The subscript t indicates that the ingrowth varies
over time because it, too, is a function of the stand density.

The probability that a tree stays alive and moves from diameter class j to j+1 between
years t and t+1 is:

d

g
b ijt

ijt = , (5)

Appendix B—
WestPro Model and
Parameters

Growth Equation

Growth Model Structure
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where g
ijt 
is the yearly growth (in inches) of a tree of species i in diameter class j, and d

is the width of a diameter class (2 inches). In turn, g
ijt 

 is a function of tree diameter, di-
ameter squared, site index, and stand basal area. The parameters of this function, esti-
mated with the data described in appendix A are in table 2.

The probability, m
ijt
, that a live tree of species i and diameter class j died between year t

and t+1 was computed as:

T

m
m ijT

ijt = ,  (6)

where m
ijT

 is the probability that a tree dies between year t and t+T, the interval between
inventories, set at 10.6 years, the average interval between inventories across all plots.
m

ijT
  was represented by the logit function:

ijT

ijT

z

z

ijT
e

e
m

+
=

1
,  (7)

where z
ijT

 is a function of tree diameter, diameter squared, site index, and stand basal
area. The parameters of this function are shown in table 3. For this and other equations,
only variables that were statistically significant or conformed with a priori expectations
were included. Where none of the explanatory variables was statistically significant or
had the expected signs, the dependent variable was assumed to be constant, and set
equal to the mean observed in the sample.

Although more complex ingrowth equations were tried during the empirical work, the final
version of the model of ingrowth, in trees per acre per year, was a linear function of stand
basal area only. The parameters of the ingrowth function are in table 4.

The equation used to predict tree volume expressed volume in cubic feet as a function of
tree diameter, diameter squared, site index, and stand basal area. The parameters of the
tree volume equations are in table 5 for trees of at least 5 inches in diameter. The volume
of smaller trees was set equal to zero.

Table 2—Parameters of diameter growth equations

Explanatory variable

Species Diameter
group Constant Diameter  squared Site index Basal area Statea

Inches Square inches Feet Square feet
per acre

Softwoods 0.035 0.0090 -0.00015 0.0016 -0.00055
Hardwoods .020 .0044 -.00011 .0008 -.00009 -.035
a 0 for Washington, 1 for Oregon.

Mortality Equation

Ingrowth Equation

Tree Volume Equation
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Table 3—Parameters of logit model for probability of tree mortality between
two inventories

Explanatory variable

Diameter
Species Constant Diameter  squared Site index Basal area

Inches Square inches Feet Square feet
per acre

Softwoods -2.42 -0.23 0.0034 0.0082 0.0029
Hardwoods .0996

Table 4—Parameters of ingrowth equation

Species Constant Basal area

Square feet
per acre

Softwoods 2.65 -0.0044
Hardwoods .74

Table 5—Parameters of tree volume equations

Explanatory variable

Diameter
Species Constant Diameter squared Site index Basal area

Inches Square inches Feet Square feet
per acre

Softwoods -64.8 -0.18 0.221 0.46 0.080
Hardwoods -23.5 -.94 .22 .24 .01
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