
Smith Creek Photo Monitoring Methods Fall 2005 
Abstract 
 The following guide can be used to replicate the photo monitoring pictures taken 
during the fall semester 2005.  It describes in detail the process of using the Ike300, a 
GPS device that takes pictures of data points, seamlessly with a program called 
MediaMapper.  This program allows a web page to be made quickly from a shapefile (the 
export from Ike300) and a background layer such as aerial photography.  These two 
programs work well independently but many problems occur when combining their 
services.  This guide explains the reasons for these problems and their solutions.  It 
proposes a detailed process that should be used in order to escape the incompatibilities 
between the two pieces of technology. 
 
Introduction 
 The Ike300 is a powerful tool that can easily take GPS points and export the data 
in the form of a shapefile compatible with all kinds of software.  A first time user 
shouldn’t have too much trouble picking it up and taking GPS points with pictures.  First 
time users may find the Ike Users Manual to be of assistance in getting familiar with 
how the Ike works. 
 The Ike comes standard with three shapefiles pre-loaded and ready to use.  There 
is a generic point shapefile, which allows the user to take GPS points and manually fill in 
a basic attribute table after the point is taken.  There is a generic polygon shapefile which 
allows the same manual entry of data except polygon data is captured.  The last standard 
shapefile serves as an example of the automation that is possible in the data capture 
process.  The user is forced to use a small keyboard that pops up to manually enter data 
on the generic shapefiles but in the city_trees shapefile the user has drop down boxes to 
chose from and other custom designs.  This example shows that the can design their own 
custom shapefile to make common data collection faster. 
 After learning how the Ike works and collects data, it is time to prepare our own 
shapefile to be used specifically for the task of photo monitoring Smith Creek.  A custom 
shapefile is needed in order to capture specific data elements that are not present in the 
generic shapefiles as well as to create output data that can be used interchangeably with 
MediaMapper.  Before you start, make sure you have the following programs 
installed. 

• Sprite Clone, Ike Sync and Active Sync (Which can be accessed from the 
Surveylab Downloads page but also can be installed directly with the 
installation CD that came with the Ike300). 

• Most Importantly – ArcPad must be installed on the computer. 
 
 



1. Process 
a. Deploying the Prototype to Ike – This step involves clearing the Ike of all 

data to start the following process from a clean slate.  If data exists on the 
Ike make sure it has been saved before proceeding with these steps. 

i. Ensure that the ike has been connected via Active Sync. 
1. When the ‘New Partnership’ box pops up asking what type of 

partnership you would like, make sure to select ‘Guest 
Partnership.’ 

ii. Start Sprite Clone from Start-> Programs-> Sprite Software-> Sprite 
Clone. 

Sprite Clone is available for download from the Surveylab Downloads page: 
http://www.surveylab.co.nz/Downloads.html.  The sprite clone license details are as 
follows:  Company – Surveylab.  License – 7299 B8E4 1C70 6C00 A6C0 375B 3FBF 
F3E4 26CA. 

iii. From the Wizard, select ‘deploy an image to a Pocket PC’ option, and 
click next. 

iv. Browse for the relevant image file ikeImage_1.4RedHenPrototype.sif 
and click Finish. 

v. Click Yes to confirm that you will overwrite all data on the ike. 
vi. Click ‘Begin Deploy’ and follow the onscreen instructions. 

vii. Close Sprite Clone. 
 
After the Ike has been completely cleaned out, the next time you try to take a GPS point 
the device will require a registration number.  That number is 854966011392.  You will 
also need to reset the declination (located in the ‘Settings’ area just before you click the 
Capture Data button).  The magnetic declination used for the first round of photo 
monitoring is 9.27. 
 

b. Step 2 - Transfer a Custom Shapefile To Ike 
i. Find the custom shapefile in the main folder (SmithCreek.shp) 

ii. Connect the ike to the computer via Active Sync. 
1. This is the default program that pops up when you plug the Ike 

into the computer. 
iii. When the ‘New Partnership’ box pops up asking what type of 

partnership you would like, make sure to select ‘Guest Partnership.’ 
iv. Copy everything in the shapefile folder (all files that combine to make 

up the shapefile and the ‘ArcPad’ file.) 
v. And Paste it into the hard drive for the ike.  You will paste these files 

to the folder   \Storage Card\ike.  Figure 3 shows the file location. 
vi. Say ‘Ok’ to replacing the existing file called ‘ArcPad.’ 

It is essential at this phase to make sure that the shapefile name contains no spaces or 
weird characters.  Ike will allow an invalid file name to be uploaded, but many 
problems will exist when you are trying to manipulate the data later on. 
 

http://www.surveylab.co.nz/Downloads.html


c. Capturing the Data 
i. Press the triangle button to launch ArcPad (if you haven’t done so you 

will now need to enter the registration number) and then the square 
button to launch the AABDCA or the data capture application. 

1. You should find the shapefile when you drop down the box. 
2. If you do not find the shapefile, exit Arcpad and the data 

capture application. 
3. Click on the Start Menu and then click on the File Explorer. 
4. Navigate to My Device\Storage Card\ike 
5. This will bring you to the location of the shapefile that you just 

copied to the ike in the previous step. 
6. Select the shapefile by clicking on the file name with the .shp 

extension. 
ii. This shapefile has been designed to work seamlessly with 

MediaMapper and only allows for manual data entry. 
 
The final product, an html web page for the public to view changes to Smith Creek after 
restoration, needs to have 5 essential pieces of data.   

• Description of the site and the bank (left or right) 
• Date photo was taken 
• Lat and Long 
• Distance the target is away from GPS device 
• Azimuth 

The Lat, Long, Distance and Azimuth will all be automatically generated in the attribute 
table of the custom shapefile after you have taken a point.  The date the photo was taken 
will not be auto filled but because the date will not be a unique value to each point, it 
does not need to be entered at this time either.  It will save time to add the date at a later 
time in an editing session within ArcMap.  The last piece of data does have to be added 
after each point/picture is taken. 

 
iii. The description of each site and the bank, left or right, must be 

manually entered into the field in the attribute table titled, ‘NAME’ 
1. You could go back and look at the pictures to decide on a name 

and the bank to save even more time, but filling in at least the 
bank will help in case you forget or can’t tell from the picture. 

iv. After capturing some test points to become familiar with the process, 
Close the Data Capture Application (DCA) and close ArcPad. 

Two tips: When capturing data, make sure to take the GPS point on the targets position, 
not the ike’s position.  This is the default setting, but check just in case (after taking a 
point, click SPATIAL, instead of FINISH).  All the photos and GPS points for my 
portion of the project were taken on the targets position.  Also, when you are manually 
entering data you must click out of the box BEFORE clicking OK to finish the GPS 
point.  If you enter data into a text box and keep the cursor present in this text box the 
data you just entered will not be saved.  Click outside the box, and then click OK. 
 



d. Transferring the Data to the Desktop 
It is important to use ike Sync for this process, because the hyperlink information will not 
be updated correctly if the files are simply copied using Windows Explorer.  ArcPad 
must also be installed by this point or errors will occur when transferring data using ike 
sync. 

i. Open ike Sync (Click Start, Programs, Surveylab and then ike Sync) 
ii. Click Tools and then click Settings. 

1. This step allows us to set the desired download location. 
iii. On the line titled ‘Desktop Data Folder’ chose or create the desired 

file location and click OK. 
1. It is suggested that it be located in c:\ike\THEtitleYOUchose 

(without any spaces). 
iv. Click the Transfer Ike to Desktop Button 
v. If all files are copied without errors move on to the next step.  If errors 

arise, double check all previous steps. 
e. Editing Data for Use in MediaMapper 

After the data has been captured, we need to manipulate the data so that MediaMapper 
can recognize it and display it properly.  The following steps will be performed in 
ArcMap.  I am assuming at least a small bit of familiarity with the program. 
 

i. Open ArcMap and add the shapefile we just created. 
ii. Display the editor toolbar and Click the Editor button to drop down a 

list of options. 
iii. Click Start Editing. 
iv. With the editor open and running, any changes you make by accident 

can be reversed. 
v. Right click on the shapefile and then click, Open Attribute Table 

We will now transform the rough data collected by the ike into the correct format 
MediaMapper recognizes.  Lat and Long do not have to be manipulated but the Date, 
Distance and Azimuth all need to be fixed. 

vi. To fix the date: find the column titled UTC. 
1. Because MediaMapper only recognizes this Date format, you 

must enter a number into this column to display a date. 
2. 38665 is November 9th 2005 and 38656 is October 31st 2005. 
3. You could manually enter in the same number over and over 

again or click on the column to highlight it, then right click to 
display a list of options. 

4. Click Calculate Values.  This option will auto fill all cells with 
a desired value 

5. In the text box enter the value you would like to see in each 
cell and click OK. 

vii. To Fix the Distance: find the column titled ikeDist. 
1. MediaMapper does not recognize this field so we must copy 

the data to the field titled ‘HDISTANCE’ 
2. Click once on the HDISTANCE field to highlight it, then right 

click to display the options. 



3. Select Calculate values. 
4. Instead of writing in a number, this time you will select the 

field that all the distance values are located (ikeDist). 
5. After selecting that field, click OK to copy all the distance 

values from the ikeDist field to the HDISTANCE field. 
viii. To fix the Azimuth Field: find the field titled ‘ikeRawBrg’ 

1. This field has autofilled all the azimuth values but 
MediaMapper does not recognize this field either. 

Although the ikeRawBrg field populates only the raw compass bearing without 
calculating the current magnetic declination, this is the field that was reported in the first 
round of photo monitoring.  The calculated bearing was not compatible with 
MediaMapper.  To replicate the pictures and stay consistent, report the raw bearing. 

2. Perform the same procedures above to move the values from 
ikeRawBrg to the field titled Azimuth. 

ix. Make any changes to the ‘NAME’ field which contains the site 
descriptions. 

x. Click Save Edits and exit the program. 
If for some reason you end up taking two different sets of data (downloaded and saved 
into two different shapefiles) and you are trying to make an HTML export, you might run 
into problems in MediaMapper.  The problem occurs when adding two shapefiles at once 
into MediaMapper.  Sometimes it will report errors, or not display the pictures of one of 
the shapefiles.  The best workaround is to merge the shapefiles into one shapefile 
containing all the points.  After this is done, make sure the image folder for the new 
shapefile contains both sets of images (you will have to copy all the images into the 
folder). 

f. Open the Exported Shapefile in Media Mapper 
With the data updated, it is now time to produce the HTML export. 

i. Open MediaMapper 
ii. Chose the ‘Create a New Media Map’ option 

iii. Browse for the folder c:\ike\THEtitleYOUchoose and enter a name for 
the Media Map. 

iv. Click File-> Add Layers 
v. Browse for the folder c:\ike\THEtitleYOUchoose and select the 

shapefile that you collected the data on. 
vi. Zoom in until you have the desired view and select File-> Export-> 

HTML. 
1. Exporting into HTML creates a webpage based on the current 

view of the map.  Whatever you were looking at will be 
captured in the export. 

At this point it is advantageous to have a working knowledge of MediaMapper in order to 
manipulate how the shapefile is displayed.  Here are a few major things to know: to 
change the symbol, go to Map-> Layer Manager-> Select the Shapefile-> Click Display 
Properties-> Click the ‘Override’ box-> and then Click on Symbols to select a different 
display.  The layer manager also allows you to arrange the order the layers are displayed.  
If you add a DOQ and wonder why it has not showed up, check the layer manager to 
make sure it is listed and in the correct position above or below other layers.  In order to 



change the label that appears when you click on a point and view the associated picture, 
you must click on Edit-> Options.  The box in figure 1 appears.  To change the fields 
displayed in the label, find the box at the bottom of the options tab titled, Media Viewer 
Caption.  If you right click in this box a long list of options appears (see figure 1).  
Selecting %Name%, %distance%, %azimuth% etc. will show the associated data in the 
label.  To show the date, chose %utcdate%. 

vii. Browse for the folder c:\ike\THEtitleYOUchoose and create a new 
subfolder called HTML.  Click OK 

viii. An options menu pops up allowing you to customize your HTML 
extract. 

1. Aside from any other changes you may want to make, you 
must customize the format of the HTML. 

2. To customize the way the HTML is set up, go to the last tab, 
Multimedia, (figure2) and click Browse in the Link Images 
Section. 

3. Find the custom script titled mmtemplate2.html  
ix. Click Ok when all the options have been decided on. 
x. Click Yes to view the HTML export now. 

xi. If the pictures do not immediately show up, you must allow your 
computer to run blocked content, or in this case ActiveX controls. 

xii. After clicking on a picture, it is evident that the forest service icon 
does not appear at the bottom of the pop up (a red X is displayed in its 
place. 

1. To make it appear, find the file named USDA.gif (in the main 
CD) 

2. Copy it, and paste it into HTML (the folder you just created)-> 
Scripts-> Images. 

Final Comments 
 The photo monitoring project undertaken during the fall semester of 2005 was 
managed by me, Chris McGough.  I will act as the primary contact for any problems 
encountered during replication.  Any technical questions about the Ike can be directed to 
Jeremy Gold jeremy.gold@survey-lab.com and questions about MediaMapper can be directed 
to either Julie Repass jrepass@RedHenSystems.com who manages their help desk, or Carol 
Snyder csnyder@RedHenSystems.com who is the Director of Marketing and Customer 
Support. 
 The conditions were crystal clear with sparse clouds during each day the photos 
were taken.  Because of the ike’s poor picture quality, it is actually easier to take photos 
on a cloudy day.  The shadows on a bright day wreak havoc on the contrast.  The flow 
was very low on every test day except for the last.  December 2nd 2005 was a few days 
after a 2.5 year rain event that went over the banks.  The flow on the last photo 
monitoring day was an estimated 6-10 inches higher than normal. 
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Reference Screen Shots 
 
 
 

 
Figure 1.  The Main Options Menu. 



 
Figure 2.  The options menu for the HTML you are creating. 



 
Figure 3.  The file structure for the ike. 



 
How to create custom views (or buttons to go straight to the area of interest)



 
 

 
These instructions (easier seen when blown up) tell how to view the html extract after you export 

it. 
 


